You are not logged in.

" Who is online? " List

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

There are 22 guests currently Online

Today, 6:54am

Thread: "Dog chewed wires, some zones won't water but some double water."

Today, 6:53am

Thread: "Stainless steel screw clamps"

Today, 6:53am

Add post to thread: "Hunter Pro C programming"

Today, 6:53am

Add post to thread: "Multiple zones running"

Today, 6:52am

Add post to thread: "Strange Issues"

Today, 6:52am

Add post to thread: "priming pump"

Today, 6:51am

Add post to thread: "3 Stations Not working"

Today, 6:50am

Thread: "Hunter head adjustment."

Today, 6:49am

Add post to thread: "Manual "run 1 zone" or "run all zones now" only works occasionally."

Today, 6:49am

Add post to thread: "Controller running, but no water"

Today, 6:49am

Main Page

Today, 6:49am

Forum: "Not Sure What's Wrong?"

Today, 6:48am

Thread: "Sprinkler Valve Pops-Up but no Water comes out"

Today, 6:47am

Add post to thread: "Seeping Head"

Today, 6:47am

Thread: "One station stopped working"

Today, 6:46am

Thread: "Sprinklers in one zone shut down before time is up"

Today, 6:46am

Add post to thread: "Missing sprinkler"

Today, 6:44am

Add post to thread: "Zone missing on automatic. (Orbit Controller)"

Today, 6:43am

Add post to thread: "Burst Pipe??"

Today, 6:42am

Add post to thread: "Multiple zones running"

Today, 6:41am

Add post to thread: "What To Do To Stop Water Going Out from On Station?"

Today, 6:39am

Thread: "Zone 1 does not pop up on timer, yet does when manually started."

There are 3 search engine robots currently online (Enable details)