You are not logged in.

" Who is online? " List

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

There are 35 guests currently Online

Today, 9:02pm

Thread: "1 ZONE HAS LOW PRESSURE"

Today, 9:00pm

Add post to thread: "Valve Removal"

Today, 9:00pm

Forum: "Not Sure What's Wrong?"

Today, 9:00pm

Add post to thread: ""Fuse" warniong on two zones"

Today, 9:00pm

Post in thread: "10 Zone Hunter System - 1 Zone on constantly"

Today, 9:00pm

Add post to thread: "Valves wont turn off"

Today, 9:00pm

Post in thread: "Not sure where leak is located"

Today, 9:00pm

Add post to thread: "I NEED help with my sprinkler heads"

Today, 8:59pm

Post in thread: "PVB, heads, line, or solenoid valve issue?"

Today, 8:59pm

Add post to thread: "Meyers 1 1/2 Hp pump not starting sprinklers"

Today, 8:59pm

Post in thread: "Thumping/Knocking Noise in Pipes for a Few Seconds when Valve Opens/Zone Comes on"

Today, 8:59pm

Post in thread: "One zone w/ low pressure"

Today, 8:59pm

Add post to thread: "Bursting Poly pipe"

Today, 8:59pm

Forum: "Not Sure What's Wrong?"

Today, 8:59pm

Thread: "troubleshoot Richdel 500 pri irrigation controller"

Today, 8:59pm

Thread: "Flowtec Pump Not Pumping Water"

Today, 8:58pm

Add post to thread: "Leaking/broken pipes"

Today, 8:58pm

Post in thread: "Hunter ICC won't automatically water higher stations"

Today, 8:58pm

Add post to thread: "4 Zones suddenly not working"

Today, 8:58pm

Add post to thread: "Control Box working ok, but no water comes on"

Today, 8:58pm

Post in thread: "Orbit Lawn Sprinklers Problem"

Today, 8:58pm

Thread: "WHAT THE HELL SIZE IS THIS?????...lol"

Today, 8:58pm

Post in thread: "Low Pressure in Two Zones"

Today, 8:58pm

Thread: "New Home: No water to system and not working"

Today, 8:58pm

Forum: "Not Sure What's Wrong?"

Today, 8:58pm

Add post to thread: "heads not shutting off"

Today, 8:57pm

Thread: "One Zone always on"

Today, 8:57pm

Add post to thread: "Leaking Weathermatic 12000 valves"

Today, 8:56pm

Thread: "One Zone always on"

Today, 8:55pm

Thread: "One Zone always on"

Today, 8:54pm

Thread: "zone 1 pulsating with weak flow"

Today, 8:53pm

Forum: "Not Sure What's Wrong?"

Today, 8:52pm

Post in thread: "Multiple Zones Running at Once"

Today, 8:50pm

Forum: "Not Sure What's Wrong?"

Today, 8:48pm

Thread: "One Zone always on"

There is one search engine robot currently online (Enable details)