You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

ejdurk

Unregistered

1

Wednesday, April 3rd 2013, 6:52pm

Sprinkler pump banging

I am working on a friend's sprinkler system. He bought the house several months ago and has no history on the system. It is a well supplied system in St Petersburg Florida. Have no idea how deep the well is or it's history. There are 3 zones with 6 to 12 head per zone. The system hadn't been used for at least 7 months and could be longer When I brought the system up it took a while to prime and when it finally got going, the pump started a "banging". By that I mean the pump and the pipes were vibrating like crazy. I wouldn't really call it a surge even though when the banging was taking place the pressure to the heads dropped way down. Then it would run OK for a little while and start banging again. Any ideas on where to start would be greatly appreciated.
Jim

Wet_Boots

Supreme Member

Posts: 4,030

Location: Metro NYC

2

Wednesday, April 3rd 2013, 8:51pm

Does it sound something like there's gravel in the pump? Lots of wells in Florida produce less water than they did when originally set up. The result can be cavitation (that gravelly noise)

Your solution is to make the system use less water. This follows from the idea that your water table has become lower, which makes the pump overwork to produce the same flow of water.

Rate this thread