You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Wet_Boots

Supreme Member

Posts: 4,081

Location: Metro NYC

11

Wednesday, June 29th 2011, 4:12pm

You and a million others, who had controllers like the Imperial. You just remove the pin from the time-of-day wheel, and it won't start on its own.

Has NJIT fallen on hard times? :D Back when it was NCE, students knew enough to read the instructions.

njitgrad

Unregistered

12

Thursday, June 30th 2011, 12:45pm

Has NJIT fallen on hard times? :D Back when it was NCE, students knew enough to read the instructions.
Touche! I've just been so busy with home renovations, I haven't had time to ready the instructions. I had a feeling removing the "daily" pins would be the answer.

Imperial owner

Unregistered

13

Thursday, July 21st 2011, 12:31pm

Manual mode

On days that you want to water, turn to auto and start the cycle. For other days that you do not want to water, turn the black switch to OFF. Pretty simple.

agam641

Unregistered

14

Wednesday, July 27th 2011, 7:25pm

Imperial Phantom 22 Valet Timer

Everything seems to be working except that I have it on automatic and just recently because of the hot spell, I timed it for 6 am and 6 pm.

I have 16 active zones set at 30 minutes. The dial turns twice around on this 11 zone timer. It takes 11 hours for it to go to the off position. This leaves 1 hour to go before it goes to the 1st zone again.

Unfortunately, it has stop going on automatically at either time.

I tried it on one time per day only and it still is not going on. Although, when i move it to the first zone, it continues through the entire 16 zones plus the other 6 unused zones.

Does anyone have an answer to my problem?

Wet_Boots

Supreme Member

Posts: 4,081

Location: Metro NYC

15

Wednesday, July 27th 2011, 8:42pm

bad microswitch, most likely

agam641

Unregistered

16

Thursday, July 28th 2011, 7:29pm

microswitch for he Imperial Phantom 22

"Where do I find this micro switch. I don't have the book anymore. It's been 18 years"

Wet_Boots

Supreme Member

Posts: 4,081

Location: Metro NYC

17

Thursday, July 28th 2011, 8:17pm

If you are going to fix that thing, you need skills enough that you wouldn't even be asking questions. There was never any repair guide on these.

Think about it a bit, and ask whether you wouldn't be happier having it repaired by pros.

Kerry

Unregistered

18

Monday, October 29th 2012, 12:06pm

Imperial Timer failure????

I too have the same timer with 6 stations. My issue is this: I went out by the pool and noticed that the station 4 was on when it shouldn't be on because the timer was off. I went to the timer and it was indeed off. I replaced the selinoid at the valve and the diaphram and it seemed to work. Mow this morning I have discovered it on again. I even place that station on zero minutes but it still went on and stayed on. The only way to get the station to shut off was to turn the main water off and on again. Is this time bad??? My last water bill was over $300. Help anyone.

mrfixit

Moderator

Posts: 1,462

Location: USA

19

Monday, October 29th 2012, 12:17pm

Sounds like the valve to me. Turn the flow control down a bit and see if that helps.

ker657

New Member

20

Monday, October 29th 2012, 12:29pm

reply to sounds like a valve

There are for some reason 4 stations on this one valve. I have replace the selinoid and the diaphram. So do u really think that if I turn down the flow down it will shut this station off and not allow it to stay on or is it really the timer instead. Remember I had this station at zero so it should have cycled right past it instead it stayed on even after the whole system shut off.

Rate this thread