You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

panchor

Unregistered

1

Thursday, July 29th 2010, 3:18pm

Pipes banging when sprinklers are on

I just have a water heater installed and since then, every time i turn on my sprinklers or they change zone, the pipes in my basement near the water heater start banging for a few seconds. The plumber also installed an expansion tank next to the water heater.

I noticed that if I close the valve that feeds water to the water heater, the banging does not occur. So the problem is either the water heater or the expansion tank.

Does anybody know how to fix it?

Thank you

Wet_Boots

Supreme Member

Posts: 3,873

Location: Metro NYC

2

Friday, July 30th 2010, 5:30am

Assuming the sprinklers connection is near the water meter (or at least "upstream" of the water heater) it should be that a check valve would stop the backwards movement of water from the expansion tank. When a zone is first opened, the expansion tank momentarily has higher pressure than the sprinkler supply.

panchor

Unregistered

3

Friday, July 30th 2010, 9:45am

Thanks for the reply. Yes, the sprinklers connection is near the water meter. Where do I need to install the check valve? Near the expansion tank, near the sprinkler connection?

Rate this thread