You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


New Member


Wednesday, June 13th 2007, 2:03pm

TORO Vision II Plus zone trouble

I'm having problems with some zones working and some not working. I have a TORO Vision II Plus timer/controller. My spring start-up man says I need a new controller, but I'm not so sure. I've had problems with a zone or two being cantankerous in years past, and it seems odd to me that this year it would run half the zones fine, and still be the controller which is the problem with those that don't work. Maybe that's it, but?

I have 10 zones. Of the first 5, only number 2 will run. Number Six is blank. Numbers Seven through 11 work fine. Occasionally, zones 1 and 5 work, but they come on at the same time, but this year they usually aren't coming on at all. This has never occurred in the past. I've examined the valve boxes in the ground, and the wires are all connected and don't appear to be leaking water.

It seems as if every year when a new person comes around in the past, if there is a problem at all, they "rewire" some connections in the box, each saying, "here's the problem." The fellow today didn't change any wires, but said the controller wasn't sending enough voltage and needed to be replaced. He did not check the valve boxes, though. If the voltage is the problem, how is managing to run half the zones OK?

I know this controller is pretty old now, but I'm reluctant to run out and buy another box, without some input from someone who isn't wanting to sell me a box -- especially since that has been "the answer" several years when it really wasn't.

I'd appreciate any ideas or help.


Rate this thread