You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

kottler

Unregistered

1

Friday, November 10th 2017, 5:36pm

Do you recognize this part?

I had a hose bib that would not shut off. I took it apart and I found this plastic thing in there. See pics at https://www.flickr.com/gp/115393210@N03/Kr5978. My hose bib works now but where did this nozzle break off from? There are nine sprinkler and drip control valves of various models and brands upstream of the hose bib on the same pressure-side pipe. All the sprinkler controllers seem to be working OK. Any suggestions? Thanks.

mrfixit

Moderator

Posts: 2,002

Location: USA

2

Friday, November 10th 2017, 7:57pm

That looks like it broke off of a Champion valve adapter. What kind of valves do you have in your yard? Maybe take a pic.
It holds the seat washer on so eventually the valve will fail or maybe it's been replaced already because once that part breaks off the valve will have problems. It might get stuck on or it might sound like it wants to come on but it's not.
The good news is the part got stuck in a faucet and not the valves. That means the hose bib might be at the end of the line so you can flush any debris out there.
Maybe after repairing a valve if needed, you can unscrew the faucet and flush it out.

This post has been edited 2 times, last edit by "mrfixit" (Nov 10th 2017, 11:50pm)


kottler

Unregistered

3

Saturday, November 11th 2017, 10:24am

Do you recognize this part?

You're right that it got stuck at the end of the line. I'll be taking the adapters off one at a time this week until I find the culprit. Thanks for the hint!

kottler

Unregistered

4

Saturday, November 11th 2017, 2:39pm

Do you recognize this part?

I have Orbit, Rainbird, and Lawn Genie valves in that line. I took each apart today and none are missing anything and they all work fine. You're right that it must have been from an old valve replaced years ago and now that part has migrated to the end of the line. Thank you.

Rate this thread