You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


New Member


Sunday, February 26th 2006, 2:54pm

Problem converting to drip


First, I shoudl say I'm a DIYer, and have not really worked with a sprinkler or drip system much. I have done lots of fairly advanced DIY projects, so I do catch on quickly. Having said that, ffter several hours of trying to complete a simple conversion, I'm really frustrated! I have two Richdel valves that were part of an existing sprinkler system when I bought this house. Last summer, I had them working with the sprinklers. I live in phoenix, so I have removed all the grass (too much work), and am trying to convert everything to drip for desert landscaping. Last week, I cut the PVC and attached 1/2" poly tubing to both valves. Ran the tubing around the yard, tested with the auto controllers, and both lines started and stopped properly. Capped both lines, attached drippers and again tested. Both lines worked fine, except I had some blowouts.

I realized I needed to install pressure regulators, so today I went and bought two (25 psi), along with the necessary connectors. Installed a pressure regulator on both lines (after the valves), and after tightenting a few connections, valve 1 turned on and ran the drippers with no problems. Line 2 did not come on. No click or hum like I usually hear when the valve turns on. After fiddling with it for a while, I removed the solenoid, went to the store and bought a new one (811). Problem 1 is that although they look the same, the bottom of the existing solenoid looks different than the new one. The new one looks like this photo (the valves look like the Irritrol 2500 except mine don't seem to have the little shut-off lever right beneath the solenoid--I see from other posts that Irritrol bought out Richdel):

The existing part doesn't have the white part at the bottom (the plunger?), just a hole up inside where the threads are. I thought that maybe the plunger was stuck in the valve, but I tried to remove it with forceps, and it seems to be permanent. So . . . I can't replace the solenoid. I unscrewed the solenoid from Valve 1, and it looks the same (a hole, not a plunger).

So, I decided to put the old solenoids back in until I can work on it again. Now Valve 1 doesn't come on, either.

These valves worked fine last weekend. I do have waterproof wire nuts on all wires. I took them off and made sure everything is properly connected and tight.

I would also be interested in knowing how to bypass the valves and just run both lines manually until I can get the valves working properly.

Any help would be appreciated.



Supreme Member

Posts: 5,308

Location: Metro NYC


Sunday, February 26th 2006, 9:59pm

If you didn't install a filter for the zones, all the drip emitters may be clogged by now. Also, the flow rates for the drip may be lower than the old valves can handle.


New Member


Monday, February 27th 2006, 2:47am

Thanks Wet Boots. The valve in the link above has a flow range .25-30 GPM, and the pressure range is 10-150 psi, which I would think would be sufficient. I can't read the Richdel model, but it looks almost identical to mine (with the exception of the lever). As I mentioned, the pressure regulator is 25 psi. Valve 1 (which worked at first) actually has many fewer drippers than Valve 2 (which didn't) and they are 1 gpm drippers, so that would seem to point to the clog issue, since both would have the same pressure. I used mostly adjustable drippers set at about 2 GPM, but I can change the few out that I used that are less than that. It may be next weekend before I can work on it, but I can flush the system, and then make sure I re-install all of the adjustable drippers and set them to a higher flow. Would any of those issues explain why there was no click when the timer should have turned the valve on??

I did install a filter, but some mud may have gotten into to the system when I added the pressure regulators.

Interestingly, when I went back outside to put things away, both zones were working. In reading other posts, I think I unscrewed the soleoid partway, which probably turned them on manually. Unfortunately, I also had a box full of water, as I had been trying to test for leaks from my pressure regulator install when the above problem occured.

Again, any help would be appreciated.


Supreme Member


Monday, February 27th 2006, 3:22am

Very confusing...however....

the new solenoids have an encapsulated plunger...the old solenoids do not.

The new solenoids have an o'ring installed on the base of the solenoid...the old do not

Possibly what has happened is mud and grim has gotten into the port under the solenoid...?

A lot can go wrong in the hole that is dug to do this type of work..but one thing is for certain, if the valve isn't humming...and the solenoid is new..probably a wire problem.

More info, more pics if you can...good luck.

Sprinkler Solutions, Inc.
Arizona and Colorado


New Member


Monday, February 27th 2006, 4:32am

Thanks so much, SprinklerGuy! I thought it was probably an electrical problem, so I'll need to solve the new vs. old solenoid problem as well as re-check the connections.I will take some photos (it was too dark last night by the time I was posting) as soon as I get a chance.

Rate this thread