You are not logged in.


Starting Member

Posts: 1

Location: USA


Thursday, June 28th 2007, 4:13am

Hunter Pro-C Program A Issue

I have a Hunter Pro-C and it has worked great up to a week ago. For some reason it stopped coming on when it was schedueled to. I checked the programing all was correct but for some reason the word "program A" was not showing up on the panel like it usally did. I have unpluged and reset everything, re-did all my times, dates and so on but when I set it to "run" it does not show the "program A". It works fine manually for 1 station and for running all stations but just can't get it to stop at the programed time. Any ideas what to check? I think I have tried everything I can think of.



Posts: 1,741

Location: USA


Thursday, June 28th 2007, 10:38am

It sounds like you know what you're doing. I'm assuming you took out the back up battery when you unplugged it. I had a problem with the Pro-C a few years ago. 3-4 years I'm guessing. They were having odd problems like yours. Even brand new out of the box. I was hesitant to install one for a couple years. I'm now back to using them with no problems. There's one timer I've never had a problem with and I've installed many many. The Hunter SRC which is now the SRC Plus. I've never had to un-install one. I'd take it back. Look for a date inside the battery compartment. That's the manufacturing date. If it's still under warranty just take it back for an over the counter exchange. Meaning free. Good luck!
If I can't fix it, it's broken!

Rate this thread