You are not logged in.

Hansston

New Member

1

Tuesday, June 20th 2006, 8:01am

Hunter I20 SS Won't Pop Up

I have an acre of lawn and have a ton of sprinklers, all PGP. When the PGP's need to be replaced, I decided to upgrade to I20 stainless steel sprinklers. I ordered 10 to test them out and when installed, they won't pop up. When I manually pull up the sprinkler with the adjustment tool, the sprinkler works fine, but I can't get the sprinkler to pop up on it's own. I tried 3 zones to no avail.

Is there an easy solution to this problem? Do the SS models need lubrication?

Wet_Boots

Supreme Member

Posts: 4,081

Location: Metro NYC

2

Tuesday, June 20th 2006, 12:26pm

Your new sprinklers have stronger springs than the old ones. You see the result.

Hansston

New Member

3

Tuesday, June 20th 2006, 1:06pm

So, my choices are to put a booster pump on my system to increase the pressure or go back to the PGP's?

Wet_Boots

Supreme Member

Posts: 4,081

Location: Metro NYC

4

Tuesday, June 20th 2006, 3:09pm

You could try swapping springs with the old heads, but basically, you stick with the PGPs

Tom

Supreme Member

5

Wednesday, June 21st 2006, 2:35pm



hunter lists the recommended operating for the pgp and I-20 at 40 psi. they also list the miniumum operating pressure as 20 psi for both heads.

you must have done something wrong and/or you have a leak on these zones resulting in very low pressure to the head.

lush96

Advanced Member

6

Tuesday, June 12th 2007, 8:31pm

i-20's are not that good a head. the 5 year warranty is the only good point. stick with the pgp's. much much more reliable head.

Rate this thread