You are not logged in.

bmckinle

New Member

Posts: 2

Location: USA

1

Friday, September 1st 2006, 6:41pm

overheating transformer on a GFI circuit

My GFI keeps popping with a Hunter Pro-C (15 zones) plugged into it--and nothing else on the circuit drawing power. Electrician claimed there was a ground wire not connected (faulted). Found one on the circut and the GFI worked for a while. Now the problem is back, so I've tried another GFI circuit in the garage to eliminate the original circuit as the problem altogether.

Now the electrician says the controller should not be on a GFI (hum??), rather it should be on a non-GFI'd circuit. Throughout this process, when I have check the transformer, it has been very hot to the touch; almost too hot to handle (130F or thereabouts). My electrical engineering background tells me something on solenoid side of this system is pulling too much power from the transformer. Moreover, the transformer is hot even when no zone is active (off) put the controller has power. Hum... I think something may be shorting somewhere sprinkler-side. Solenoids? Should I have the sprinkler installer come and check them? I paid him to get it working right, so I don't think I should fix it for him.

Any help would be greatly appreciated.

Bryan
Bryan

mrfixit

Moderator

Posts: 1,459

Location: USA

2

Friday, September 1st 2006, 7:48pm

First of all let me say find yourself another electrician. The guy is clueless and I'm using his flipflop of a story as proof. That timer has it's own safety feature via a fuse. Gfi or no gfi. No difference unless that outlet was installed incorrectly. It cracks me up when I see an electriction or a plumber working on an irrigation system. There's obviously a problem though. A transformer at 130 degrees sounds dangerous to me. I'm suggesting there's something shorting out inside the transformer and the more it shorts out the hotter it's going to get. You mentioned the solenoids drawing too much power. If there was a problem with the solenoids I'm thinking it should blow the fuse in the timer. Did you by any chance put a much too large fuse insid the timer? Let me say that a transformer is always warm to the touch even when the sprinklers aren't running. But not so hot it burns you. Not on a Hunter Pro C. Try this. I'd try disconnecting everything. Wires at the solenoids. Transformer from the timer. Leave the transformer plugged in and see if it's still super hot. It's a place to start and I wish you luck. Trial and error is my answer for you.
If I can't fix it, it's broken!

mrfixit

Moderator

Posts: 1,459

Location: USA

3

Friday, September 1st 2006, 9:51pm

Hi there. Looks like mrfixit made a mistake. Maybe I'm the one who's clueless. I Have a ProC on my truck and there's isn't a optional fuse to change. My apologies. But it does have a reset button. I'm still going with the bad transformer angle though. I suppose it's possible the built in circuit breaker is malfunctioning. How about this. Are you running hundreds of feet of thin guage wire to the valves? Good luck!
If I can't fix it, it's broken!

bmckinle

New Member

Posts: 2

Location: USA

4

Monday, September 4th 2006, 6:22am

Disconnecting the suspect solenoids and all from the transformer and isolating it will definiting tell me if something in the controller unit is bad. Good idea. All heavy gauge wiring in yard (100's of feet though---.6 acre lot). I thought there might be a fuse on the controller itself (uh, most devices like this would have one). I agree that the GFI circuit is not the problem. Anyway, since I posted this an irrigation hand came on and checked all zones (worked of course) and said the transformer was a little warm but that everything seemed ok. We ran this 2 minute/zone test on 15 zones (30 minutes) on another GFI circuit with no GFI faults. I've even run it another time or two since with no GFI fault trip (running an extension cord across the garage-yuk). This indicates something on the original circuit is faulty. The GFI itself will not reset now, so this looks like the problem. The irrigation fellow said that a surge had occurred and that this had damaged the transformer. The electrician is coming out tomorrow, so I'll have him replace the GFI and I'll run the sprinkler with him there. Also, I'll get Hunter on the phone and ask them if I should replace that transformer.

Thanks a bunch for the info.

Bryan
Bryan

Rate this thread