You are not logged in.


Starting Member

Posts: 1

Location: USA


Sunday, April 9th 2006, 5:47am

Richdel 205s valve problems

This is going to be lengthy!
My zone wasn't getting much pressure, so I checked connections, opened the bleeder valve a little and suddenly pressure picked up. After running for a little while, the valve wouldn't close.

I then closed the bleeder a little and it seemed to close the station properly. Now, I don't get any functionality and have found the zone underwater. I removed the standing water, turned all water off, removed the cover - exposing the diaghram. I turned the diaghram over, resecured and adjusted the bleeder valve such that no water would come out of the bleeder. Now the solenoid didn't sound like it is working - so I lightly tapped it and it makes noise.

The unfortunate part - now no water is coming out of any of the sprinklers. Do I need a new valve? In scanning the forum, can I simply replace the valve and solenoid mechanism only - without having to dig up, cut out the old valve and all of that headache? Any other ideas??




Supreme Member


Sunday, April 9th 2006, 8:49am can still buy diaprams and solenoids for this valve...chances are the solenoid is fine...BUT....if you can find the valve, buy it and replace both at the same time.

Sprinkler Solutions, Inc.
Arizona and Colorado


New Member

Posts: 6

Location: USA


Monday, April 10th 2006, 2:31pm

I agree, if you replace the diaphram and solenoid you should be fine. As you take the old diaphram out look into the valve body for debri. You may need to flush the valve before reassembling.
WetYet? Joe Pell

Rate this thread