You are not logged in.


Starting Member

Posts: 1

Location: USA


Tuesday, April 6th 2004, 5:57am

Bad FEBCO 765 Backflow Valve?

I'm about to be unemployed and don't want to pay to have someone come out to fire-up my system for the summer. It was installed last summer and winterized by the installer in the fall. All of the outside valves were left half-open through the winter. Plastic caps for both Testcocks were off though the winter. Today I opened all the valves, from the water supply and both sides of the backflow valve. Controller off, with all solenoid valves closed. I left the testcock caps off. When I open the inlet valve, water sprays from Testcock 1. When I plug Testcock 1, water sprays from Testcock 2 and from under the canopy. When I plug both testcocks, the system seems to pressurize, but there are small leaks coming from both testcocks.

Questions 1: What's wrong? 2: For summer use, should the Testcocks be plugged with the plastic caps? 3: There are winterization instructions all over the web, but I can't find instructions on how to "summerize" the system - know of any?


Supreme Member


Tuesday, April 6th 2004, 4:07pm

The testcocks have a "slot" that is most likely open. You can use a flatblade screwdriver to close the valves. When the slot is perpendicular to the testcock it is closed.


Advanced Member

Posts: 229

Location: USA


Wednesday, April 7th 2004, 6:04am

Just need to close up the testcocks-
You mentioned that you had the install last summer. How long is your warranty for with the installer??

If you decide to manage your system yourself and something breaks ytou might just void out your warranty. Replacement parts can run you more expenive than having your contractor in-

Rate this thread