You are not logged in.

JAW

New Member

Posts: 3

Location: USA

1

Tuesday, February 24th 2004, 7:31am

Problem with Toro PVB 53300

Hi,

I just bought an existing home that has a Toro sprinkler system. The system works great, but when the system is off the PVB 53300 continues to leak water out the top. So, I have been turning the knobs to off while its not in use so the side of my house does not flood and my water bill does not get crazy. The problem is that I forget to turn it back on so the system fails to water on scheduled days.

Im wondering if there is something I can do to fix the valve, or does it just have to be replaced. And if it needs to be replaced can someone recommend somewhere where I can find it....so far I have been uanble to locate the valve at my local Home Depot or Lowe's...and cannot seem to locate it online.

Thanks in advance for your help!! [8D]

mrwettech

Advanced Member

Posts: 53

Location: USA

2

Tuesday, February 24th 2004, 3:29pm

There are a few possible causes to your problem. Most of them have to do with the internal components like the check assembly, o-ring, and spring. You will need to disassemble to check them though. Most Toro sites should provide you with this procedure. Look under "product manuals". Hope this helps.

JAW

New Member

Posts: 3

Location: USA

3

Tuesday, February 24th 2004, 7:37pm

Thanks!

I found the manual with the break-out diagram. Im going to take it appart and hope its just got dirt in it or something easy since I dont have replacment parts. Do you (or anyone) know where I can buy a replacement, or parts?

JAW

New Member

Posts: 3

Location: USA

4

Wednesday, March 3rd 2004, 7:49am

****o?? Is this thing on?

RVLI

Supreme Member

Posts: 460

Location: USA

5

Thursday, March 4th 2004, 12:33pm

Toro doesn't make backflow devices anymore, and I have heard of quite frequent problems with them. My suggestion would just to be to replace it, as I doubt Toro makes parts for them anymore? I may be wrong.

Rate this thread