You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Starting Member


Sunday, May 12th 2013, 3:57pm

low pressure at one zone too

I have a well pump just for sprinkler system, nelson brand for about 14 year old
last year I winterized myself, and notice zone 5 was not much water coming out.
this spring zone 5 has low pressure, although the sprinkler head popped up, and the water can come out, it is no mist at all. I tried to clean the zone 5 valve myself, no use, I can't tell whether the valve is good or not. I also measured the pressure while the zone 5 is on by attaching the pressure meter to the well water faucet outside the house, and it read 20psi. The other zones have 40psi...
Does this basically indicate that I have a leakage at the zone 5? if so, how can I find where it might be?
I changed one of the sprinkler heads last year in zone 5 using Hunter PCP, the pressure at that time was OK...

Your advice and thoughts are really appreciated.


Active Member

Posts: 46

Location: Kansas City


Sunday, May 12th 2013, 5:37pm

I would start with the head you replaced last year. It sounds like you have exceeded your available flow for the zone. I would change the nozzle to a lower flow rate and see if the helps the zone.

Similar threads

Rate this thread