You are not logged in.


New Member


Tuesday, May 7th 2013, 6:08pm

Orbit valves not opening

Got them fixed - never had this ever happen but FYI - on the orbit valves when you take the cover off to check the diaphragm check and make sure the small chrome rod is still attached to the underside of the cover - without it the valves will not operate. The only thing I can figure they came loose and are down in the manifold but after about 10 minutes trying to fish them out (blindly) with my extendable magnet I gave up and took the tops off another set of valves and put them on.



Posts: 1,738

Location: USA


Tuesday, May 7th 2013, 6:43pm

You're right. The rebuild kit comes with a diaphragm and that rod thing as two different pieces in a package. I tried it without the pin on two different occasions. It wouldn't function with the controller either time. When I put the pin in along with the diaphragm it worked just fine.
The valves being repaired didn't have a metering pin originally. hmm.

Similar threads

Rate this thread