You are not logged in.

Oldguy

New Member

1

Saturday, March 9th 2013, 3:04pm

Trying to revive and old rainbird system that works "Half-way"

I have an old rainbird system (about 10 years) old. It is stuck in on position. Using master switch I can turn it on and it cycles through it's 6 cycles watering fine. After the 6th cycle it continues running but no water coming out. I have to turn it off with the master switch. (there are actuually 8 cycles and the last 2 are not wired, contrary to the manual instruction, but this system has worked ok for 10 years). I can remove the circuit board. Is there any way to get it repaired? I would just replace the whole system except I am afraid I will find that the wiring inlet holes are in different places on the box and I will get involved in a major wiring job. The only help rainbird offers is buy a new system. Any advice appreciated. Oldman

Wet_Boots

Supreme Member

Posts: 5,123

Location: Metro NYC

2

Saturday, March 9th 2013, 3:31pm

more than a brand name is needed - model number helps - photos help even better

Oldguy

New Member

3

Sunday, March 10th 2013, 11:13am

Old Rainbird system details

Details on old rainbird system - ESP-4, ESP-6, ESP-8 Dated 19-AU-98-01, ESP 931763. Model 57009,

Wet_Boots

Supreme Member

Posts: 5,123

Location: Metro NYC

4

Sunday, March 10th 2013, 5:39pm

There won't be any issues replacing an ESP-8 with a new ESP controller.

mrfixit

Moderator

Posts: 1,988

Location: USA

5

Monday, March 11th 2013, 3:35am

Have you tried resetting the controller? If it still acts up after doing a reset then go for a new controller.

Old_guy

Unregistered

6

Monday, March 11th 2013, 10:44am

Replace and/or reset

No, I haven't tried reset, but I will and if that doesn't help I now feel better about replacing it. THANKS a lot for your help. Oldsguy

Rate this thread