You are not logged in.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

jedisme

New Member

1

Sunday, May 27th 2012, 12:45am

Demming Crane old pump stupor!

Well, I have been a lurcker her for quite sometime and now have decided to join the gang here. I'll get right to it, I bought this old pump awhile ago the pump runs great no issues there I get a good PSI (60-65) and GPM (14) hold a prime fairly well it will lose a prime if I leave a valve open. My question is, anyway the 1' inlet is restricting my GPM? I've tried to find more information on this pump and have had little success I am not sure of the HP or can I find a model number I took a few pictures in hopes of finding out more about this pump. Also I am soon to attempt an irrigation system for my lawn still in the preperation process.
jedisme has attached the following files:
  • well4.jpg (19.85 kB - 0 time downloaded )
  • well5.jpg (19.5 kB - 2 times downloaded - Last download: May 29th 2012, 8:17am)
  • well6.jpg (17.14 kB - 0 time downloaded )

Wet_Boots

Supreme Member

Posts: 4,020

Location: Metro NYC

2

Sunday, May 27th 2012, 6:50am

Try to work up a pump setup with a pressure tank and a pressure switch. Only use zone valves with flow controls, which you will throttle down for assured closing. Do all that, and you have the best chance of maintaining prime. You need a check valve on the inlet side, if you don't already have a foot valve.

Rate this thread