You are not logged in.

sylvie chen



Sunday, April 22nd 2012, 12:27pm

nelson solorain actuator battery powered

Recently I noticed that the nelson solorain battery powered actuator no longer seems to work in the shut off position (solenoid is in the down position). I thought it was a weak battery but both actuators have the same problem.
I replaced the batteries but no go. The innitrol valves are connected to a main water line with a shut off valve.

I thought the problem could be high pressure so I reduced the water flow through the valve to the minimum but the water keeps flowing.

I checked the bleeder tube in the innitrol valve was blocked and they are clear. I made sure the solenoid was in the down position prior to assembling and testing. Still no go.

Question is: is the problem with the nelson actuator or the innitrol valve membranes/springs?


Supreme Member

Posts: 4,823

Location: Metro NYC


Sunday, April 22nd 2012, 1:42pm

test this by replacing the solorain with a standard solenoid, and see if the valve is still sticking open

Central Irrigation

Supreme Member

Posts: 371

Location: Central Minnesota


Sunday, April 22nd 2012, 2:07pm

I have not worked with the solorain product before, but is it possible that the unit is unscrewed slightly? Forgive my ignorance with this product, but irritrol DC selonoids have magnets that actually hold the plunger up while the valve is in operation. Is it possible this product works the same? I know a tap on the top or side of the irritrol or toro dc selonoid is usually enough to break the magnetism between selonoid and plunger, thus turning off the valve. Again, I don't know if the solorain operates in the same fashion.

Rate this thread