You are not logged in.

1

Saturday, December 5th 2009, 10:02pm

new installation leaks and clogs

I have just finished installing my first attempt at a drip irrigation system. This system was designed by a local irrigation company. I am putting in 20-30 nut trees and using micro sprinklers. I also put in a well to support the irrigation.

Everything seemed to work OK at first (last week), but now that I have covered all the trenches, there seems to be random sprinkler failures, not always the same ones - some are weak, some sputter, and some just leak drops.

Also, a number of the quick connect rainbird elbow are leaking where they connect to the male adaptor connector into the 1" pvc. This is a push on connection with no glue or compression, so I don't know of anything to do to fix them. Since I cannot pull the connectors apart without damage, I would have to replace the male adaptor and elbow (not sure if the 1/2 tubing would have to be trimmed).

The sprinklers are DAN-PC? and there does not seem to be a way to troublshoot them either.

I am using a controller box, and I will not be monitoring the system daily - it must be trustworthy. I don't want to loose trees due to random failures of sprinklers.

Any suggestions? ?(

Wet_Boots

Supreme Member

Posts: 4,077

Location: Metro NYC

2

Monday, December 14th 2009, 7:19am

What have you heard from the designers?

3

Friday, December 18th 2009, 6:06pm

Designers will replace any leaking parts, and have explained how to clean the sprinklers.

JimLewis

Active Member

Posts: 10

Location: Beaverton, OR

4

Tuesday, December 29th 2009, 12:32am

So the water source is a well??? What kind of filtration have you installed on the system to protect the drip system from sediment coming in from the well water?
Jim Lewis
Lewis Landscape Services - Oregon

Portland Oregon Sprinkler Repair

Rate this thread