You are not logged in.

Adryan

Unregistered

1

Tuesday, May 26th 2009, 2:09am

Irritrol - Richdel 217B not fully opening

Hello all,



I have made a setup with 11 Irritrol / Richdel 217B - 2"valves. They are used to switch on / of the drip lines. I have a problem the valves are not opening fully every time..lets say they work o.k. for 50%. It are used valves. When I use the manual bleed screw the valve will fully open, and stay open untill the valve is switched of. I've cleaned everything out and can find any cracks/dirt in the valves. I'm using a low flow in the valves (22GPM, 45PSI). The controller works o.k., as are the sollenoids. The way the controller works is as follow: the valve is opened and a second later the pump is powered. The pressure is build up in the system in about 7 seconds to 45PSI, but the valves often don't fully open.

any input would be appriciated!

regards,

Adryan

worachj

Advanced Member

Posts: 63

Location: Eagan, Mn

2

Tuesday, May 26th 2009, 8:53am

That valve has an operational pressure range of 20-150 psi. It needs a minimum pressure of 20 psi to open/close. It could be a pressure/flow problem. I don’t know anything about pumps so I don’t have any suggestions on how to correct the problem other than switching to a valve with a lower operational pressure range. Sorry, maybe someone else can provide a helpful solution.

http://www.irritrol.com/pdf/sellsheet_200B.pdf

This post has been edited 1 times, last edit by "worachj" (May 26th 2009, 9:11am)


Wet_Boots

Supreme Member

Posts: 3,880

Location: Metro NYC

3

Tuesday, May 26th 2009, 10:55am

22 gpm is rather below the operating range of any 2-inch valve, outside of those built for specifically drip.

It would be better to have some pressure on the supply side of the valve, before they open.

Rate this thread