You are not logged in.

Not Sure What's Wrong?

If you are not sure what is wrong with your sprinkler system, this section is set aside for giving advice on general troubleshooting and diagnostic techniques. There are tools and techniques that are vital!

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by rsuber (Jun 30th 2005, 4:10am)

2 382

by HooKooDooKu

(Jul 22nd 2005, 12:44pm)

by cwrouse (Jun 27th 2010, 10:38am)

1 381

by mrfixit

(Jun 28th 2010, 3:45am)

by Busted Valve (Jul 14th 2005, 6:45am)

3 381

by Wet_Boots

(Jul 14th 2005, 9:07am)

by NewtoAZ (Dec 9th 2011, 2:16pm)

4 380

by new to az

(Jan 11th 2012, 2:39pm)

by rxjohn (Jun 29th 2010, 7:55pm)

3 380

by Wet_Boots

(Jun 30th 2010, 8:48am)

by nadine (May 6th 2013, 12:58pm)

3 378

by mrfixit

(May 7th 2013, 3:43am)

by luv2bean (Jul 11th 2011, 7:06pm)

2 378

by servicetechMA

(Jul 18th 2011, 7:18pm)

by apetree4 (Jun 6th 2010, 9:40pm)

1 378

by HooKooDooKu

(Jun 8th 2010, 8:23am)

by Yardman (Jun 20th 2004, 4:17am)

3 378

by Yardman

(Jul 1st 2004, 3:24pm)

by whatsavalve (Sep 24th 2011, 6:18pm)

4 377

by whatsavalve

(Sep 26th 2011, 12:49pm)



868 Threads - 3,665 Posts (average 0.73 Posts per Day)