You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by ragtop69 (Oct 12th 2012, 7:11pm)

1 886

by Wet_Boots

(Oct 12th 2012, 10:24pm)

by Mikeee (Apr 22nd 2007, 9:24am)

2 878

by jmduke7

(Apr 22nd 2007, 2:21pm)

by labert (Jan 3rd 2004, 6:11am)

3 873

by labert

(Jan 7th 2004, 2:15pm)

by LawnJockey (Oct 29th 2011, 10:39am)

1 862

by mrfixit

(Oct 29th 2011, 1:33pm)

by guill34 (Jun 4th 2007, 6:49am)

2 862

by guill34

(Jun 4th 2007, 1:11pm)

by cassian (Aug 16th 2005, 6:44am)

1 857

by RidgeRun05

(Aug 16th 2005, 1:28pm)

by BVISailor (Oct 31st 2009, 10:11am)

1 854

by worachj

(Oct 31st 2009, 12:47pm)

by kenttab (May 21st 2012, 5:51pm)

1 853

by mrfixit

(May 21st 2012, 8:58pm)

by Eastern chubbytool (Aug 8th 2010, 2:49pm)

2 853

by hi.todd

(Aug 10th 2010, 11:57am)

by pohall@kivexmail.com (May 13th 2006, 9:21am)

1 851

by jmduke7

(Aug 17th 2006, 3:13pm)

Show

Statistics:

437 Threads - 1,665 Posts (average 0.35 Posts per Day)