You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by orgits (Apr 9th 2011, 5:10pm)

2 1,289

by Mitchgo

(Apr 10th 2011, 2:29am)

by harrisst14 (Jun 10th 2012, 6:29pm)

1 1,272

by mrfixit

(Jun 10th 2012, 8:13pm)

by jkd1976@yahoo.com (Mar 15th 2007, 4:11pm)

7 1,270

by SprinklerGuy

(Mar 17th 2007, 2:22am)

by John199 (Aug 14th 2011, 3:57pm)

4 1,254

by hi.todd

(Aug 15th 2011, 7:29pm)

by Mikeee (Apr 22nd 2007, 9:24am)

2 1,240

by jmduke7

(Apr 22nd 2007, 2:21pm)

by fwoodall (Aug 28th 2005, 6:01pm)

2 1,226

by squints

(Jul 31st 2011, 2:16pm)

by crashxx (Apr 28th 2012, 12:16pm)

4 1,224

by crashxx

(May 1st 2012, 9:15am)

by denm31 (Apr 4th 2011, 3:11pm)

6 1,219

by Wet_Boots

(Apr 7th 2011, 1:00pm)

by wmhallii (Aug 4th 2005, 9:51am)

2 1,194

by wmhallii

(Aug 5th 2005, 4:16am)

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 1,172

by 4U2NVME

(Jul 17th 2013, 12:01pm)

Show

Statistics:

505 Threads - 1,934 Posts (average 0.37 Posts per Day)