You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by bobspitler (Jun 6th 2011, 7:10am)

1 338

by Mitchgo

(Jun 6th 2011, 9:34pm)

by lou40 (Nov 9th 2011, 4:15pm)

3 640

by Wet_Boots

(Nov 13th 2011, 8:15am)

by BRL (Jun 13th 2007, 2:03pm)

0 1,565

No reply

by JT (Mar 9th 2014, 8:08pm)

1 212

by Wet_Boots

(Mar 10th 2014, 5:56pm)

by Rsnic (Jun 17th 2012, 2:10pm)

6 2,099

by Wet_Boots

(Jun 20th 2012, 10:13am)

by Bob B (Oct 18th 2014, 9:31am)

17 344

by Wet_Boots

(Nov 1st 2014, 6:44am)

by nightshark (Sep 9th 2013, 3:11pm)

3 547

by mrfixit

(Sep 9th 2013, 6:05pm)

by csnugg (Jun 26th 2006, 4:10pm)

0 560

No reply

by PSpatches (Apr 28th 2009, 10:31am)

1 285

by Candance

(May 9th 2009, 9:13pm)

by beachdoc (May 19th 2012, 1:37pm)

5 1,127

by pavelow

(Oct 30th 2013, 9:51pm)

Show

Statistics:

462 Threads - 1,707 Posts (average 0.37 Posts per Day)