You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Kpierce (Apr 12th 2013, 10:36pm)

1 160

by Wet_Boots

(Apr 13th 2013, 10:46am)

by Ianjanson (Apr 10th 2013, 1:37pm)

2 192

by Ianjanson

(Apr 10th 2013, 7:37pm)

by Binks (Apr 10th 2013, 1:28am)

1 146

by mrfixit

(Apr 10th 2013, 3:02am)

by Trabecca (Mar 13th 2013, 6:22pm)

7 387

by Trabecca

(Mar 18th 2013, 8:23am)

by Island Sprinklers (Mar 12th 2013, 10:47am)

1 300

by Wet_Boots

(Mar 12th 2013, 11:42am)

by nowaterflow (Mar 8th 2013, 3:52pm)

3 205

by Wet_Boots

(Mar 9th 2013, 3:46pm)

by Marvel (Jan 19th 2013, 6:54am)

7 750

by Marvel

(Jan 22nd 2013, 7:49pm)

by Terri (Jan 9th 2013, 6:46am)

1 257

by Wet_Boots

(Jan 9th 2013, 11:08am)

by mikesegall@aol.com (Dec 25th 2012, 6:20pm)

1 329

by Wet_Boots

(Dec 26th 2012, 8:32am)

by rockypoint (Nov 26th 2012, 6:02pm)

2 454

by mrfixit

(Nov 26th 2012, 7:30pm)

Show

Statistics:

420 Threads - 1,567 Posts (average 0.35 Posts per Day)