You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by asegal (Oct 5th 2006, 7:43am)

4 1,119

by asegal

(Oct 6th 2006, 10:52am)

by bherholz (May 16th 2011, 12:06pm)

5 1,116

by mrfixit

(Jun 7th 2011, 5:46pm)

by svsprinklers (May 19th 2010, 9:29pm)

2 1,113

by PhoenixDen

(Jun 24th 2010, 11:27am)

by larbec7 (Jun 6th 2009, 5:07pm)

9 1,111

by Wet_Boots

(Jun 9th 2009, 12:52pm)

by Marvel (Jan 19th 2013, 6:54am)

7 1,098

by Marvel

(Jan 22nd 2013, 7:49pm)

by Caltino (Apr 12th 2013, 7:18pm)

12 1,030

by Wet_Boots

(Apr 27th 2013, 7:42am)

by fwoodall (Aug 28th 2005, 6:01pm)

2 1,006

by squints

(Jul 31st 2011, 2:16pm)

by lbfalgi (Aug 30th 2011, 6:15pm)

1 1,001

by Central Irrigation

(Aug 30th 2011, 8:38pm)

by wmhallii (Aug 4th 2005, 9:51am)

2 996

by wmhallii

(Aug 5th 2005, 4:16am)

by Garden Guy (May 7th 2007, 9:22am)

10 980

by lush96

(May 14th 2007, 8:22pm)

Show

Statistics:

436 Threads - 1,669 Posts (average 0.36 Posts per Day)