You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Lonesomedave (Oct 16th 2015, 7:38am)

1 433

by Wet_Boots

(Oct 16th 2015, 10:46am)

by JT (Mar 9th 2014, 8:08pm)

2 669

by scbsprinkler

(May 6th 2016, 8:32pm)

by Rsnic (Jun 17th 2012, 2:10pm)

6 4,495

by Wet_Boots

(Jun 20th 2012, 10:13am)

by Bob B (Oct 18th 2014, 9:31am)

17 1,189

by Wet_Boots

(Nov 1st 2014, 6:44am)

by mellow (May 31st 2015, 7:15pm)

4 362

by mrfixit

(Jun 2nd 2015, 4:08pm)

by Handy Ran (Jun 6th 2016, 4:53pm)

1 159

by Handy Ran

(Jun 9th 2016, 12:24am)

by PAP (Aug 19th 2015, 10:04am)

2 675

by PAP

(Sep 8th 2015, 9:57am)

by nightshark (Sep 9th 2013, 3:11pm)

3 942

by mrfixit

(Sep 9th 2013, 6:05pm)

by csnugg (Jun 26th 2006, 4:10pm)

0 798

No reply

by PSpatches (Apr 28th 2009, 10:31am)

1 440

by Candance

(May 9th 2009, 9:13pm)

Show

Statistics:

513 Threads - 1,964 Posts (average 0.37 Posts per Day)