You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Lonesomedave (Oct 16th 2015, 7:38am)

1 338

by Wet_Boots

(Oct 16th 2015, 10:46am)

by JT (Mar 9th 2014, 8:08pm)

1 477

by Wet_Boots

(Mar 10th 2014, 5:56pm)

by Rsnic (Jun 17th 2012, 2:10pm)

6 3,635

by Wet_Boots

(Jun 20th 2012, 10:13am)

by Bob B (Oct 18th 2014, 9:31am)

17 1,019

by Wet_Boots

(Nov 1st 2014, 6:44am)

by mellow (May 31st 2015, 7:15pm)

4 289

by mrfixit

(Jun 2nd 2015, 4:08pm)

by PAP (Aug 19th 2015, 10:04am)

2 558

by PAP

(Sep 8th 2015, 9:57am)

by nightshark (Sep 9th 2013, 3:11pm)

3 800

by mrfixit

(Sep 9th 2013, 6:05pm)

by csnugg (Jun 26th 2006, 4:10pm)

0 743

No reply

by PSpatches (Apr 28th 2009, 10:31am)

1 397

by Candance

(May 9th 2009, 9:13pm)

by beachdoc (May 19th 2012, 1:37pm)

5 1,595

by pavelow

(Oct 30th 2013, 9:51pm)

Show

Statistics:

497 Threads - 1,879 Posts (average 0.36 Posts per Day)