You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by guill34 (Jun 4th 2007, 6:49am)

2 910

by guill34

(Jun 4th 2007, 1:11pm)

by rcajun36 (Jun 26th 2006, 5:13am)

3 1,775

by xpedient

(Jun 26th 2006, 6:53am)

by archiejobs (May 31st 2006, 4:18am)

2 366

by archiejobs

(May 31st 2006, 4:24am)

by janeandjoseph (Jul 6th 2004, 11:05pm)

2 276

by janeandjoseph

(Jul 7th 2004, 8:03pm)

by jlynnrose (Mar 16th 2004, 1:33pm)

1 329

by RVLI

(Mar 16th 2004, 2:57pm)

by abcoker (May 9th 2014, 2:43pm)

5 387

by Wet_Boots

(May 23rd 2014, 7:04am)

by SprinklerMaps (Apr 27th 2014, 10:13pm)

0 268

No reply

by PerryNZ (Mar 12th 2014, 10:57pm)

5 409

by PerryNZ

(Mar 14th 2014, 12:16am)

by JT (Mar 9th 2014, 8:08pm)

1 304

by Wet_Boots

(Mar 10th 2014, 5:56pm)

by tico (Jun 15th 2013, 8:58pm)

0 530

No reply

Show

Statistics:

458 Threads - 1,728 Posts (average 0.36 Posts per Day)