You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by cjohnson2020 (Jul 26th 2013, 4:31pm)

2 345

by mrfixit

(Jul 27th 2013, 2:59am)

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 804

by 4U2NVME

(Jul 17th 2013, 12:01pm)

by Pippilo (Jul 1st 2013, 9:15pm)

3 492

by mrfixit

(Jul 2nd 2013, 3:07am)

by GraemeDunkley (May 4th 2013, 10:50pm)

5 716

by electrifiedmale

(Jun 30th 2013, 7:14pm)

by BessMan94 (Jun 24th 2013, 8:45pm)

3 452

by mrfixit

(Jun 25th 2013, 8:32pm)

by WHomeowner (Jul 24th 2011, 2:16pm)

10 2,020

by PennyInHeels

(Jun 25th 2013, 3:52pm)

by 7907 (May 3rd 2013, 12:55am)

2 366

by PennyInHeels

(Jun 25th 2013, 9:49am)

by tico (Jun 15th 2013, 8:58pm)

0 501

No reply

by RonBLaGrone (Jun 4th 2013, 11:05am)

2 543

by Ronblagrone

(Jun 12th 2013, 10:23pm)

by DBLTRGR (Jun 9th 2013, 7:14pm)

1 311

by Wet_Boots

(Jun 9th 2013, 8:14pm)

Show

Statistics:

472 Threads - 1,758 Posts (average 0.36 Posts per Day)