You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by bobspitler (Jun 6th 2011, 7:10am)

1 249

by Mitchgo

(Jun 6th 2011, 9:34pm)

by lou40 (Nov 9th 2011, 4:15pm)

3 441

by Wet_Boots

(Nov 13th 2011, 8:15am)

by BRL (Jun 13th 2007, 2:03pm)

0 1,328

No reply

by JT (Mar 9th 2014, 8:08pm)

1 38

by Wet_Boots

(Mar 10th 2014, 5:56pm)

by Rsnic (Jun 17th 2012, 2:10pm)

6 1,184

by Wet_Boots

(Jun 20th 2012, 10:13am)

by nightshark (Sep 9th 2013, 3:11pm)

3 318

by mrfixit

(Sep 9th 2013, 6:05pm)

by csnugg (Jun 26th 2006, 4:10pm)

0 446

No reply

by PSpatches (Apr 28th 2009, 10:31am)

1 205

by Candance

(May 9th 2009, 9:13pm)

by beachdoc (May 19th 2012, 1:37pm)

5 673

by pavelow

(Oct 30th 2013, 9:51pm)

by daniels (Aug 7th 2007, 11:14am)

5 2,957

by MrMark757

(Aug 9th 2010, 2:36am)

Show

Statistics:

418 Threads - 1,564 Posts (average 0.35 Posts per Day)