You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by gobris (May 14th 2013, 9:45am)

3 347

by Wet_Boots

(May 16th 2013, 8:30am)

by grey (Aug 24th 2012, 6:29pm)

1 397

by grey

(Aug 25th 2012, 2:19pm)

by fmayerjr (Aug 2nd 2012, 10:47am)

1 234

by Wet_Boots

(Aug 2nd 2012, 2:16pm)

by chrisratz (Jun 27th 2012, 7:40pm)

4 388

by chrisratz

(Jun 29th 2012, 11:18pm)

by PintoDr (Jun 28th 2012, 11:50pm)

5 574

by Wet_Boots

(Jun 29th 2012, 10:15pm)

by jrebcarlson (Jun 11th 2012, 5:40pm)

2 504

by GatorGuy

(Jun 12th 2012, 8:36am)

by dse (Jun 8th 2012, 5:58am)

2 321

by Wet_Boots

(Jun 8th 2012, 8:48am)

by kannan (May 18th 2011, 5:07pm)

4 1,186

by Wet_Boots

(May 27th 2012, 10:31am)

by crashxx (Apr 28th 2012, 12:16pm)

4 642

by crashxx

(May 1st 2012, 9:15am)

by patk (Sep 18th 2011, 2:17pm)

2 582

by patk

(Sep 18th 2011, 3:41pm)

Show

Statistics:

430 Threads - 1,626 Posts (average 0.36 Posts per Day)