You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Lonesomedave (Oct 16th 2015, 7:38am)

1 433

by Wet_Boots

(Oct 16th 2015, 10:46am)

by 09KR0058 (Oct 13th 2015, 6:11pm)

1 235

by 09KR0058

(Oct 13th 2015, 6:42pm)

by MichaelABQ (Sep 15th 2015, 1:11am)

1 233

by mrfixit

(Sep 15th 2015, 4:19am)

by Dagobah (Sep 3rd 2015, 3:46pm)

3 789

by Evergreen Sprinkler

(Sep 11th 2015, 9:41am)

by 88goldwing (Sep 1st 2015, 2:28pm)

12 793

by 88goldwing

(Sep 8th 2015, 5:36pm)

by JimsLawn (Sep 8th 2015, 2:33pm)

0 303

No reply

by PAP (Aug 19th 2015, 10:04am)

2 681

by PAP

(Sep 8th 2015, 9:57am)

by Artie (Sep 2nd 2015, 7:27am)

1 449

by Wet_Boots

(Sep 2nd 2015, 8:10am)

by GT6812 (Aug 28th 2015, 8:40am)

2 408

by GT6812

(Aug 31st 2015, 11:15am)

by mjtalmadge (Sep 11th 2011, 2:30pm)

11 8,797

by wgn1213

(Aug 18th 2015, 1:23pm)

Show

Statistics:

516 Threads - 1,973 Posts (average 0.37 Posts per Day)