You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by jbbnet (Aug 19th 2004, 5:11pm)

3 189

by SamIV

(Aug 29th 2004, 5:43am)

by buster99ranger (Aug 25th 2002, 7:49pm)

1 278

by micjeep1

(Aug 22nd 2004, 12:05pm)

by I am (Aug 4th 2004, 4:50pm)

1 289

by SprinklerGuy

(Aug 10th 2004, 5:57am)

by rickesco (Jul 28th 2004, 8:13am)

3 209

by aquamatic

(Jul 29th 2004, 10:36am)

by janeandjoseph (Jul 6th 2004, 11:05pm)

2 213

by janeandjoseph

(Jul 7th 2004, 8:03pm)

by jmm1804 (Jun 20th 2004, 2:34pm)

0 102

No reply

by jmm1804 (Jun 3rd 2004, 11:49am)

2 270

by jmm1804

(Jun 7th 2004, 12:53pm)

by dan2125 (Apr 10th 2004, 2:17pm)

1 143

by RVLI

(Apr 13th 2004, 5:30pm)

by boosted50 (Mar 18th 2004, 4:55am)

5 519

by boosted50

(Mar 20th 2004, 1:24pm)

by jlynnrose (Mar 16th 2004, 1:33pm)

1 264

by RVLI

(Mar 16th 2004, 2:57pm)

Show

Statistics:

440 Threads - 1,685 Posts (average 0.36 Posts per Day)