You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by joe decoste (Mar 19th 2011, 11:56am)

1 405

by Wet_Boots

(Mar 20th 2011, 7:29am)

by gregson (Jul 22nd 2006, 10:14am)

2 403

by nestors

(Aug 2nd 2006, 6:26pm)

by lkc91311 (Jun 26th 2011, 11:25pm)

0 402

No reply

by 0303maz (Jun 12th 2012, 9:20am)

1 401

by mrfixit

(Jun 12th 2012, 9:45am)

by sprinklerookie (Jun 6th 2006, 5:21am)

1 399

by jmduke7

(Aug 16th 2006, 6:36pm)

by clm716 (Aug 7th 2011, 9:58am)

1 397

by Central Irrigation

(Aug 7th 2011, 10:49am)

by sirlar (Jul 20th 2012, 2:40pm)

0 390

No reply

by edincary (Oct 3rd 2008, 8:31pm)

1 390

by mrfixit

(Oct 3rd 2008, 11:05pm)

by Gremlin274 (Jun 12th 2005, 12:57pm)

1 388

by Wet_Boots

(Jun 12th 2005, 1:13pm)

by Evergreen Sprinkler (Aug 4th 2015, 5:43pm)

0 386

No reply



518 Threads - 1,977 Posts (average 0.37 Posts per Day)