You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Oscar S. Ramirez (Mar 21st 2014, 5:28pm)

1 135

by mrfixit

(Mar 22nd 2014, 1:58am)

by MEL88 (Jul 19th 2012, 12:20pm)

1 166

by GatorGuy

(Jul 19th 2012, 2:14pm)

by sanddido (Oct 11th 2007, 3:39am)

1 276

by mrfixit

(Oct 11th 2007, 2:03pm)

by Tee Jay (May 17th 2007, 8:38am)

3 163

by Bill Painter

(May 21st 2007, 1:12pm)

by Drski (Jul 29th 2011, 11:50am)

5 521

by Drski

(Aug 9th 2011, 11:04am)

by Rendaug (Jan 18th 2004, 12:31pm)

3 186

by Rendaug

(Feb 8th 2004, 10:37am)

by Ianjanson (Apr 10th 2013, 1:37pm)

2 226

by Ianjanson

(Apr 10th 2013, 7:37pm)

by gerald (May 31st 2006, 5:44am)

2 142

by jmduke7

(Aug 17th 2006, 3:03pm)

by Benmt (Jul 25th 2014, 8:34pm)

1 32

by Wet_Boots

(Jul 26th 2014, 6:30am)

by gregson (Jul 22nd 2006, 10:14am)

2 134

by nestors

(Aug 2nd 2006, 6:26pm)

Show

Statistics:

430 Threads - 1,626 Posts (average 0.36 Posts per Day)