You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 393

by 4U2NVME

(Jul 17th 2013, 12:01pm)

by korangu2004 (Aug 8th 2006, 7:54am)

22 25,739

by kjaaka

(Jul 18th 2013, 7:19pm)

by cjohnson2020 (Jul 26th 2013, 4:31pm)

2 171

by mrfixit

(Jul 27th 2013, 2:59am)

by pjmckellar (Jul 27th 2013, 8:25am)

1 174

by Central Irrigation

(Jul 27th 2013, 9:42am)

by sdguy (Mar 10th 2013, 3:15pm)

3 310

by Wet_Boots

(Jul 31st 2013, 10:41am)

by Freddyfrom fl (Aug 6th 2013, 6:49pm)

1 161

by Wet_Boots

(Aug 6th 2013, 9:29pm)

by Bwilson2 (Aug 13th 2013, 10:12pm)

2 217

by mrfixit

(Aug 14th 2013, 12:28pm)

by edwildesr (Oct 7th 2007, 7:02pm)

2 1,297

by mrfixit

(Aug 26th 2013, 8:00pm)

by mydogcleo (Aug 28th 2013, 10:11am)

1 186

by Wet_Boots

(Aug 28th 2013, 1:36pm)

by Gansmanms (Nov 7th 2012, 9:10pm)

7 949

by marian

(Sep 2nd 2013, 5:37pm)

Show

Statistics:

421 Threads - 1,570 Posts (average 0.36 Posts per Day)