You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by bron7fan@cox.net (Oct 15th 2011, 5:15pm)

2 367

by mrfixit

(Oct 16th 2011, 2:26am)

by Towelie427 (Sep 1st 2014, 7:10pm)

4 366

by Wet_Boots

(Oct 5th 2014, 2:45pm)

by maddog (Sep 8th 2011, 5:48pm)

1 366

by grey

(Sep 9th 2011, 11:40am)

by billt (Aug 28th 2010, 10:20am)

1 365

by Wet_Boots

(Aug 28th 2010, 11:21am)

by ash13 (Jun 1st 2014, 10:06am)

4 361

by Central Irrigation

(Jun 1st 2014, 6:17pm)

by MEL88 (Jul 19th 2012, 12:20pm)

1 361

by GatorGuy

(Jul 19th 2012, 2:14pm)

by SpritzCan (Apr 21st 2012, 8:33pm)

2 361

by GatorGuy

(Apr 23rd 2012, 8:47am)

by SteveM099 (Jun 19th 2006, 1:50am)

1 361

by Wet_Boots

(Jun 19th 2006, 6:17am)

by 0303maz (Jun 12th 2012, 9:20am)

1 360

by mrfixit

(Jun 12th 2012, 9:45am)

by joe decoste (Mar 19th 2011, 11:56am)

1 360

by Wet_Boots

(Mar 20th 2011, 7:29am)

Show

Statistics:

505 Threads - 1,935 Posts (average 0.37 Posts per Day)