You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by evergreenz (Sep 3rd 2011, 2:33am)

2 201

by evergreenz

(Sep 3rd 2011, 12:08pm)

by Gremlin274 (Jun 12th 2005, 12:57pm)

1 201

by Wet_Boots

(Jun 12th 2005, 1:13pm)

by porterville cemetery (Nov 1st 2011, 2:23pm)

1 198

by Wet_Boots

(Nov 1st 2011, 3:12pm)

by bron7fan@cox.net (Oct 15th 2011, 5:15pm)

2 198

by mrfixit

(Oct 16th 2011, 2:26am)

by mugentuner (Aug 30th 2004, 12:30pm)

1 197

by mugentuner

(Sep 6th 2004, 8:44am)

by schlaiss (Jul 1st 2010, 9:25pm)

1 196

by Wet_Boots

(Jul 2nd 2010, 8:59am)

by Roger Stover (Jun 16th 2009, 11:09am)

4 195

by hi.todd

(Jun 19th 2009, 10:27pm)

by tabong (Jun 18th 2006, 5:10pm)

1 195

by Wet_Boots

(Jun 19th 2006, 5:44am)

by jcmckinney1 (Oct 6th 2011, 10:38am)

1 194

by Wet_Boots

(Oct 6th 2011, 6:55pm)

by mikem (Jan 4th 2004, 7:33pm)

0 194

No reply

Show

Statistics:

457 Threads - 1,702 Posts (average 0.37 Posts per Day)