You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by jhardwick (Jun 10th 2006, 1:26pm)

0 222

No reply

by AWCiesiel (Jul 13th 2012, 8:42pm)

1 433

by mrfixit

(Jul 14th 2012, 12:39am)

by bron7fan@cox.net (Oct 15th 2011, 5:15pm)

2 198

by mrfixit

(Oct 16th 2011, 2:26am)

by Eclectic (May 17th 2010, 2:01pm)

0 182

No reply

by Tullamoredew1 (Jun 19th 2009, 8:24pm)

1 192

by hi.todd

(Jun 19th 2009, 10:23pm)

by Wet_Boots (May 8th 2011, 7:43am)

0 282

No reply

by bowlesev (May 30th 2007, 9:43pm)

0 142

No reply

by Caltino (Apr 12th 2013, 7:18pm)

12 968

by Wet_Boots

(Apr 27th 2013, 7:42am)

by kenken55 (Aug 5th 2010, 10:55am)

2 517

by kenken1955

(Aug 28th 2010, 5:32am)

by Gerrit Van de Haar (Jun 5th 2010, 2:40pm)

3 265

by HooKooDooKu

(Jun 9th 2010, 11:12am)

Show

Statistics:

457 Threads - 1,702 Posts (average 0.37 Posts per Day)