You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by wingnut (Jul 9th 2009, 10:29pm)

1 383

by mrfixit

(Jul 10th 2009, 2:31pm)

by trapkoch (Jul 5th 2009, 10:20am)

1 470

by mrfixit

(Jul 5th 2009, 12:46pm)

by lydiaE (Jun 25th 2009, 11:39am)

1 565

by HooKooDooKu

(Jul 1st 2009, 11:31am)

by Bill Pajerski (Jun 26th 2009, 8:18am)

1 459

by Wet_Boots

(Jun 26th 2009, 8:58am)

by bbruck (Jun 20th 2009, 7:11pm)

1 1,228

by Wet_Boots

(Jun 21st 2009, 8:31am)

by Hammy69 (Jun 16th 2009, 9:46am)

1 355

by hi.todd

(Jun 19th 2009, 10:29pm)

by Tullamoredew1 (Jun 19th 2009, 8:24pm)

1 309

by hi.todd

(Jun 19th 2009, 10:23pm)

by PSpatches (Apr 28th 2009, 10:31am)

1 396

by Candance

(May 9th 2009, 9:13pm)

by water (Oct 23rd 2008, 8:47am)

1 593

by mrfixit

(Oct 23rd 2008, 10:24am)

by edincary (Oct 3rd 2008, 8:31pm)

1 333

by mrfixit

(Oct 3rd 2008, 11:05pm)

Show

Statistics:

496 Threads - 1,876 Posts (average 0.36 Posts per Day)