You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Marvel (Jan 19th 2013, 6:54am)

7 1,056

by Marvel

(Jan 22nd 2013, 7:49pm)

by garen (Aug 8th 2012, 10:41pm)

7 630

by Wet_Boots

(Aug 24th 2012, 8:00am)

by JA (May 9th 2010, 11:27am)

7 4,875

by Wet_Boots

(May 3rd 2011, 6:55am)

by BenC (Apr 10th 2007, 6:32pm)

7 583

by BenC

(Apr 17th 2007, 5:38pm)

by jkd1976@yahoo.com (Mar 15th 2007, 4:11pm)

7 872

by SprinklerGuy

(Mar 17th 2007, 2:22am)

by johncdbass (Oct 21st 2006, 10:40am)

7 2,043

by Wet_Boots

(Oct 23rd 2006, 3:40pm)

by spensito (Feb 16th 2006, 6:52am)

7 369

by lush96

(Mar 19th 2006, 7:16pm)

by noquarter (May 24th 2014, 1:22pm)

6 153

by Wet_Boots

(May 26th 2014, 6:22am)

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 658

by 4U2NVME

(Jul 17th 2013, 12:01pm)

by rsteffan (Aug 1st 2012, 6:14pm)

6 578

by Wet_Boots

(Aug 22nd 2012, 10:52am)

Show

Statistics:

455 Threads - 1,700 Posts (average 0.36 Posts per Day)