You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by whitty (Apr 20th 2012, 8:09am)

10 735

by GatorGuy

(Apr 23rd 2012, 8:45am)

by Jonas_ (Mar 13th 2012, 9:40am)

10 2,335

by Wet_Boots

(Mar 16th 2012, 8:14am)

by Dennis (Oct 15th 2007, 7:30am)

1 703

by edwildesr

(Nov 5th 2007, 7:53am)

by GraemeDunkley (May 4th 2013, 10:50pm)

5 694

by electrifiedmale

(Jun 30th 2013, 7:14pm)

by Trabecca (Mar 13th 2013, 6:22pm)

7 797

by Trabecca

(Mar 18th 2013, 8:23am)

by grey (Aug 24th 2012, 6:29pm)

1 500

by grey

(Aug 25th 2012, 2:19pm)

by brobinson (Jun 12th 2010, 7:44am)

8 2,205

by Wet_Boots

(Mar 31st 2012, 4:43pm)

by LawnJockey (Oct 29th 2011, 10:39am)

1 886

by mrfixit

(Oct 29th 2011, 1:33pm)

by t_shea (Sep 18th 2010, 10:46am)

5 2,642

by Wet_Boots

(Sep 20th 2010, 1:01pm)

by RedArt (Aug 15th 2010, 11:03am)

3 1,736

by mrfixit

(Aug 31st 2010, 2:23pm)

Show

Statistics:

437 Threads - 1,667 Posts (average 0.35 Posts per Day)