You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by wjmoore (Aug 1st 2004, 8:04am)

2 1,416

by nestors

(Oct 31st 2004, 1:30pm)

by mjtalmadge (Sep 11th 2011, 2:30pm)

4 2,168

by Jlinfield

(Jul 4th 2014, 11:42am)

by WS-1 (May 9th 2010, 4:29pm)

28 8,219

by Romeo

(Jun 10th 2014, 3:57am)

by JT (Mar 9th 2014, 8:08pm)

1 165

by Wet_Boots

(Mar 10th 2014, 5:56pm)

by lybrand (Aug 30th 2012, 3:54pm)

1 474

by Wet_Boots

(Aug 30th 2012, 4:50pm)

by nrwe (Jul 19th 2012, 1:57pm)

4 512

by mrfixit

(Jul 20th 2012, 3:06pm)

by Rsnic (Jun 17th 2012, 2:10pm)

6 1,930

by Wet_Boots

(Jun 20th 2012, 10:13am)

by Jonas_ (Mar 13th 2012, 9:40am)

10 1,815

by Wet_Boots

(Mar 16th 2012, 8:14am)

by Brun (Apr 29th 2008, 6:59am)

4 1,784

by hi.todd

(Nov 16th 2011, 4:49pm)

by hudr0004 (Sep 12th 2011, 10:16am)

4 525

by hudr0004

(Oct 24th 2011, 8:38am)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)