You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Island Sprinklers (Mar 12th 2013, 10:47am)

1 300

by Wet_Boots

(Mar 12th 2013, 11:42am)

by Trabecca (Mar 13th 2013, 6:22pm)

7 387

by Trabecca

(Mar 18th 2013, 8:23am)

by Binks (Apr 10th 2013, 1:28am)

1 146

by mrfixit

(Apr 10th 2013, 3:02am)

by Ianjanson (Apr 10th 2013, 1:37pm)

2 192

by Ianjanson

(Apr 10th 2013, 7:37pm)

by Kpierce (Apr 12th 2013, 10:36pm)

1 160

by Wet_Boots

(Apr 13th 2013, 10:46am)

by Idonthaveone (Apr 17th 2013, 3:50pm)

1 193

by mrfixit

(Apr 17th 2013, 5:56pm)

by Caltino (Apr 12th 2013, 7:18pm)

12 480

by Wet_Boots

(Apr 27th 2013, 7:42am)

by richard1975 (Apr 28th 2013, 7:12pm)

1 133

by Scott76

(May 2nd 2013, 2:06pm)

by Rmiclette (May 5th 2013, 6:49am)

2 196

by Scott76

(May 5th 2013, 11:41am)

by rickthedrummer101 (May 11th 2013, 2:26pm)

1 199

by Wet_Boots

(May 11th 2013, 5:08pm)

Show

Statistics:

420 Threads - 1,567 Posts (average 0.35 Posts per Day)