You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by abcoker (May 9th 2014, 2:43pm)

5 178

by Wet_Boots

(May 23rd 2014, 7:04am)

by rickesco (Jul 28th 2004, 8:13am)

3 178

by aquamatic

(Jul 29th 2004, 10:36am)

by SprinklerMaps (Apr 27th 2014, 10:13pm)

0 175

No reply

by JT (Mar 9th 2014, 8:08pm)

1 175

by Wet_Boots

(Mar 10th 2014, 5:56pm)

by mikem (Jan 4th 2004, 7:33pm)

0 175

No reply

by gerald (May 31st 2006, 5:44am)

2 171

by jmduke7

(Aug 17th 2006, 3:03pm)

by mugentuner (Aug 30th 2004, 12:30pm)

1 171

by mugentuner

(Sep 6th 2004, 8:44am)

by evergreenz (Sep 3rd 2011, 2:33am)

2 167

by evergreenz

(Sep 3rd 2011, 12:08pm)

by Gremlin274 (Jun 12th 2005, 12:57pm)

1 167

by Wet_Boots

(Jun 12th 2005, 1:13pm)

by SpritzCan (Apr 21st 2012, 8:33pm)

2 166

by GatorGuy

(Apr 23rd 2012, 8:47am)

Show

Statistics:

436 Threads - 1,648 Posts (average 0.36 Posts per Day)