You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by keitht (Apr 11th 2006, 3:53pm)

1 231

by BSME

(Apr 12th 2006, 5:45am)

by clm716 (Aug 7th 2011, 9:58am)

1 229

by Central Irrigation

(Aug 7th 2011, 10:49am)

by Hammy69 (Jun 16th 2009, 9:46am)

1 229

by hi.todd

(Jun 19th 2009, 10:29pm)

by rickesco (Jul 28th 2004, 8:13am)

3 229

by aquamatic

(Jul 29th 2004, 10:36am)

by killerj (May 25th 2009, 10:32am)

0 227

No reply

by jhardwick (Jun 10th 2006, 1:26pm)

0 227

No reply

by maddog (Sep 8th 2011, 5:48pm)

1 226

by grey

(Sep 9th 2011, 11:40am)

by JT (Mar 9th 2014, 8:08pm)

1 225

by Wet_Boots

(Mar 10th 2014, 5:56pm)

by ahersman (Sep 30th 2009, 1:37pm)

1 224

by ahersman

(Sep 30th 2009, 6:15pm)

by ash13 (Jun 1st 2014, 10:06am)

4 223

by Central Irrigation

(Jun 1st 2014, 6:17pm)

Show

Statistics:

436 Threads - 1,669 Posts (average 0.36 Posts per Day)