You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by mikesegall@aol.com (Dec 25th 2012, 6:20pm)

1 666

by Wet_Boots

(Dec 26th 2012, 8:32am)

by Terri (Jan 9th 2013, 6:46am)

1 567

by Wet_Boots

(Jan 9th 2013, 11:08am)

by Marvel (Jan 19th 2013, 6:54am)

7 2,165

by Marvel

(Jan 22nd 2013, 7:49pm)

by nowaterflow (Mar 8th 2013, 3:52pm)

3 712

by Wet_Boots

(Mar 9th 2013, 3:46pm)

by Island Sprinklers (Mar 12th 2013, 10:47am)

1 862

by Wet_Boots

(Mar 12th 2013, 11:42am)

by Trabecca (Mar 13th 2013, 6:22pm)

7 1,672

by Trabecca

(Mar 18th 2013, 8:23am)

by Binks (Apr 10th 2013, 1:28am)

1 521

by mrfixit

(Apr 10th 2013, 3:02am)

by Ianjanson (Apr 10th 2013, 1:37pm)

2 649

by Ianjanson

(Apr 10th 2013, 7:37pm)

by Kpierce (Apr 12th 2013, 10:36pm)

1 523

by Wet_Boots

(Apr 13th 2013, 10:46am)

by Idonthaveone (Apr 17th 2013, 3:50pm)

1 566

by mrfixit

(Apr 17th 2013, 5:56pm)

Show

Statistics:

517 Threads - 1,975 Posts (average 0.37 Posts per Day)