You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by runningfreak (May 25th 2011, 7:32pm)

1 155

by Wet_Boots

(May 25th 2011, 8:29pm)

by keitht (Apr 11th 2006, 3:53pm)

1 155

by BSME

(Apr 12th 2006, 5:45am)

by Hammy69 (Jun 16th 2009, 9:46am)

1 154

by hi.todd

(Jun 19th 2009, 10:29pm)

by DBLTRGR (Jun 9th 2013, 7:14pm)

1 153

by Wet_Boots

(Jun 9th 2013, 8:14pm)

by AdamT (Jun 7th 2012, 12:00pm)

2 153

by AdamT

(Jun 7th 2012, 9:14pm)

by mikem (Jan 4th 2004, 7:33pm)

0 152

No reply

by ahersman (Sep 30th 2009, 1:37pm)

1 151

by ahersman

(Sep 30th 2009, 6:15pm)

by g (Apr 19th 2011, 1:56pm)

0 150

No reply

by RodQ (Jul 11th 2010, 12:54pm)

2 150

by hi.todd

(Jul 12th 2010, 12:49pm)

by maddog (Sep 8th 2011, 5:48pm)

1 149

by grey

(Sep 9th 2011, 11:40am)

Show

Statistics:

419 Threads - 1,565 Posts (average 0.35 Posts per Day)