You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by Roger Stover (Jun 16th 2009, 11:09am)

4 468

by hi.todd

(Jun 19th 2009, 10:27pm)

by melprint (Jul 11th 2009, 9:06am)

1 467

by mrfixit

(Jul 11th 2009, 11:59am)

by grph (Aug 31st 2005, 3:56am)

1 466

by Jazzer K

(Sep 2nd 2005, 6:25pm)

by alf51175 (Aug 1st 2011, 9:53pm)

3 465

by alf51175

(Aug 2nd 2011, 8:02pm)

by Artie (Sep 2nd 2015, 7:27am)

1 461

by Wet_Boots

(Sep 2nd 2015, 8:10am)

by rickesco (Jul 28th 2004, 8:13am)

3 461

by aquamatic

(Jul 29th 2004, 10:36am)

by Moggie (Jun 4th 2011, 10:48am)

1 457

by Mitchgo

(Jun 5th 2011, 1:28pm)

by PSpatches (Apr 28th 2009, 10:31am)

1 457

by Candance

(May 9th 2009, 9:13pm)

by abhnoclue (Jun 16th 2007, 10:57am)

2 457

by abhnoclue

(Jun 17th 2007, 6:20am)

by shellbeach (Sep 27th 2010, 4:18pm)

2 455

by Wet_Boots

(Sep 28th 2010, 1:11pm)



518 Threads - 1,977 Posts (average 0.37 Posts per Day)